# Contents

## Installation

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Requirements</td>
<td>1</td>
</tr>
<tr>
<td>Supported Operating Systems</td>
<td>1</td>
</tr>
<tr>
<td>Additional Software</td>
<td>1</td>
</tr>
<tr>
<td>Components</td>
<td>1</td>
</tr>
<tr>
<td>Demo Mode</td>
<td>1</td>
</tr>
<tr>
<td>Server Installation</td>
<td>1</td>
</tr>
<tr>
<td>Step 1 – Installation of Database Server</td>
<td>1</td>
</tr>
<tr>
<td>Step 2 – BIOMA Installation (on Server)</td>
<td>7</td>
</tr>
<tr>
<td>Step 3 – Creation of Database</td>
<td>9</td>
</tr>
<tr>
<td>Step 4 – Server Configuration (only in multi user operation)</td>
<td>10</td>
</tr>
<tr>
<td>Client Installation</td>
<td>16</td>
</tr>
<tr>
<td>Step 1 – BIOMA Installation (on Client)</td>
<td>16</td>
</tr>
<tr>
<td>Step 2 – Configure Client Database Connection</td>
<td>17</td>
</tr>
<tr>
<td>Trouble Shooting</td>
<td>18</td>
</tr>
<tr>
<td>Changing of Server Authentication Mode (only with existing installations)</td>
<td>18</td>
</tr>
</tbody>
</table>

## User Manual for Plant Admins and Users

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Demo Mode</td>
<td>23</td>
</tr>
<tr>
<td>Setup of BIOMA Interface (a)</td>
<td>23</td>
</tr>
<tr>
<td>Logon (u)</td>
<td>23</td>
</tr>
<tr>
<td>Install License (a)</td>
<td>23</td>
</tr>
<tr>
<td>Open Plant Document (u)</td>
<td>23</td>
</tr>
<tr>
<td>Edit Plant Configuration (a)</td>
<td>24</td>
</tr>
<tr>
<td>Import Configuration 1 (a)</td>
<td>27</td>
</tr>
<tr>
<td>Import Configuration 2 (a)</td>
<td>28</td>
</tr>
</tbody>
</table>
### Menu Description

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File</strong></td>
<td>Logon (u) .............................................. 32</td>
</tr>
<tr>
<td></td>
<td>Logoff (u) ................................................ 33</td>
</tr>
<tr>
<td></td>
<td>Open Plant Document (u) .................................. 33</td>
</tr>
<tr>
<td></td>
<td>NEW Plant Document (e) .................................... 33</td>
</tr>
<tr>
<td></td>
<td>Save as a Template (e) .................................... 33</td>
</tr>
<tr>
<td></td>
<td>Exit (u) .................................................. 33</td>
</tr>
<tr>
<td><strong>Edit</strong></td>
<td>Edit Plant Configuration (a) .................................. 33</td>
</tr>
<tr>
<td></td>
<td>Edit Oven Line Properties (a) ................................. 35</td>
</tr>
<tr>
<td></td>
<td>Import Operation Data (u) .................................... 37</td>
</tr>
<tr>
<td></td>
<td>CSV Import Configuration (a) ................................ 38</td>
</tr>
<tr>
<td></td>
<td>Edit Operation Data (e) ...................................... 39</td>
</tr>
<tr>
<td></td>
<td>Calculate (u) ............................................... 39</td>
</tr>
<tr>
<td></td>
<td>Show Generated Source (d) .................................. 40</td>
</tr>
<tr>
<td></td>
<td>Edit Calculation Source (d) ................................. 40</td>
</tr>
<tr>
<td><strong>Reporting</strong></td>
<td>Export / Edit Report Package (a) ............................ 40</td>
</tr>
<tr>
<td></td>
<td>Import Report Package (a) .................................... 43</td>
</tr>
<tr>
<td></td>
<td>Building Reports (e) ......................................... 43</td>
</tr>
<tr>
<td></td>
<td>Export Online Calculation Results (e) ......................... 44</td>
</tr>
<tr>
<td><strong>Extras</strong></td>
<td>Options (a) ................................................ 44</td>
</tr>
<tr>
<td></td>
<td>Administration (a) .......................................... 45</td>
</tr>
</tbody>
</table>
Help (u) ........................................................................................................................................ 47
About (a)...................................................................................................................................... 47
INSTALLATION

You have to distinguish between client and server installation:

- Server installation refers to installing on a computer that serves as a database server
- Client installation refers to installing on a computer that only hosts the BIOMA software alone.

If you install for a single user both installations will be carried out on the same computer.

SYSTEM REQUIREMENTS

SUPPORTED OPERATING SYSTEMS

- Windows XP SP3
- Windows Vista
- Windows 7
- Windows Server 2003
- Windows Server 2008

ADDITIONAL SOFTWARE

- Microsoft Excel (to process exported data)

COMPONENTS

Normally the components needed are already included in the above mentioned operating systems. If not click the following links to download the components:

- Microsoft .NET Framework 2.0 (or 3.5)
- Windows Installer 3.1 (or higher)

DEMO MODE

For running BIOMA in demo mode no database installation is required. Thus it is only necessary to follow the installation guidelines under Client Installation Step 1!

SERVER INSTALLATION

“Microsoft SQL Server 2005” is used as database server. If this database server is not available on your system you can download the free “Microsoft SQL Server 2005 Express Edition Service Pack 3”.

STEP 1 – INSTALLATION OF DATABASE SERVER

- Execute the downloaded “SQLEXPR.exe”.
- Accept the license terms and click “Next”.

BIOMA
• Click “Install”.

• Click “Next”.
- Click “Next”.

- Enter your name and click “Next”.
• Click “Next”.

• Choose “Mixed Mode”. It is recommended to choose a secure password for the database administrator (sa). If you set one you will need it again in “Step 3 – Creation of Database”.
• Click “Next”.
- Click “Next”.  

- Click “Next”.  

- Click “Next”.
• Click “Next”.

• Click “Next”.

• Click “Next”.

The following components will be installed:

• SQL Server Database Services
  (Database Services)
• Click “Finish”.

STEP 2 – BIOMA INSTALLATION (ON SERVER)

This is necessary because together with the installation of the BIOMA software an additional tool called “BIOMA Database Setup Utility” is installed, that can be used to create the database (cf. Step 4).

• Execute “setup.exe” in BIOMA folder.
• Click “Next”.
• Select “Everyone” or “Just me” and click “Next”.

• Click “Next”.
**STEP 3 – CREATION OF DATABASE**

To create a database the “BIOMA Database Setup Utility” can be used. It is of cause also possible for a database admin to create the database manually.

- Select “START > All Programs > BIOMA 2.2.1304 > Database Setup Utility”.
- On tab “Database server” click “Test connection”. If you choose a different mode than “Windows Authentication” the login (“sa”) and password data from step 1 have to be used.
On tab “Installation” click “Create database”. If user name and password for BIOMA client are changed here, these changes must be considered during configuration of database connection on the client computer.

STEP 4 – SERVER CONFIGURATION (ONLY IN MULTI USER OPERATION)

If the BIOMA software should only run on the computer that is hosting the database server you can skip Step 4.

But if the database server has to be accessed from a different computer (client) it must be reachable from within the network. The necessary configurations can be carried out with “SQL Server Configuration Manager” that is also part of “Microsoft SQL Server 2005 Express Edition”.

10 • Installation
• Select “START > All Programs > Microsoft SQL Server 2005 > Configuration Tools > SQL Server Configuration Manager”.
• Select “SQL Server 2005 Network Configuration > Protocols for SQLEXPRESS. Right click “TCP/IP” and select “Properties”.

![SQL Server Configuration Manager](image1)

• On “Protocol” tab set “Enabled” to “Yes”.

![TCP/IP Properties](image2)

• On “IP Addresses” tab under “IP All” set TCP Port to 1433. Click “OK”.

![TCP/IP Properties](image3)
Additionally configure an exception for TCP port 1433 in your firewall. The following description is for Windows 7:

- Click “START”. Enter Firewall in the “Search” field. Select “Windows Firewall” from the search results. Click “Advanced Settings”.

- Select “Inbound Rules” and click “New Rule”.
- Click “Rule Type” and select “Port”. Click “Next”.

- Click “Protocol and Ports”, select “TCP” and enter 1433 under “Special local ports”. Click “Next”.


Select “Allow the connection” and click “Next”.

Click “Next”.
• Enter a name for the exception rule and click “Finish”.
CLIENT INSTALLATION

If the BIOMA software should run on the computer that is hosting the database server you can skip Step 1 because the software should be already installed there (cf. step 2 of the server installation).

STEP 1 – BIOMA INSTALLATION (ON CLIENT)

- Execute “setup.exe” in BIOMA folder.
- Click “Next”.
- Select “Everyone” or “Just me” and click “Next”.
Click “Next”.

Confirm Installation

The installer is ready to install Bioma 2.0.1312 on your computer.
Click “Next” to start the installation.

Click “Close”.

Installation Complete

Bioma 2.0.1312 has been successfully installed.
Click “Close” to exit.

Please use Windows Update to check for any critical updates to the .NET Framework.

STEP 2 – CONFIGURE CLIENT DATABASE CONNECTION

If the standard installation of the database server has been performed nothing has to be changed. If a different database server should be accessed or e.g. windows authentication shall be used the setting can be changed under “Extras > Options”.

- Start BIOMA.
- Logon with “User name” and “Password” and install a valid license (cf. section User Manual).
• Select “Extras > Options”.
• On the “Database” tab state the IP address or the name of the server that should be used. Click “Test connection”.

If the warning “Error establishing database connection!” is displayed the server is not configured for “SQL Server Authentication” and “Windows Authentication” should be used. Alternatively the server authentication mode can be changed (cf. Trouble Shooting).

TROUBLE SHOOTING

CHANGING OF SERVER AUTHENTICATION MODE (ONLY WITH EXISTING INSTALLATIONS)

In previous BIOMA versions (before 1.0.901) the server authentication mode was set to “Windows Authentication Mode” only. If you want to keep the old database server you can change the authentication with the free software “Microsoft SQL Server Management Studio Express”.

• Execute “SQLServer2005_SSMSEE.msi as admin and click “Next”.

![Database Configuration Screen]

![Connection Success Screen]
• Accept the license terms and click “Next”.

• Enter your name and click “Next”.

• Click “Next”.

• Click “Install”.

Microsoft SQL Server Management Studio Express Setup

Registration Information

The following information will personalize your installation.

Enter your name and the name of your organization in the fields below:

Name:

Company:

• Click “Next”.

Microsoft SQL Server Management Studio Express Setup

Feature Selection

Select the program features you want installed.

Feature description

Install management tools for running SQL Server, including SQL Server Management Studio Express.

Installation path

C:\Program Files\Microsoft SQL Server\
• Click “Finish”.

• Select “START > All Programs > Microsoft SQL Server 2005 > SQL Server Management Studio Express”.
• Click “Connect”.
• Right click the database server and choose “properties”.

• Select “Security”, choose “SQL Server and Windows Authentication mode” and click “OK”.

• Close the “SQL Server Management Studio Express” window.
The letter in the bracket directly after a heading refers to necessary minimum access rights (user < administrator < expert < developer).

A user has only the rights to import operational data and display the results of the calculation for several parameters.

An administrator has the additional rights to perform plant and program configurations and to create report packages.

A developer has the additional rights to display and edit the calculation algorithm.

**DEMO MODE**

When BIOMA is run in demo mode it is NOT possible to import data or report packages. All changes applied to the sample data will be deleted when the software is closed.

**SETUP OF BIOMA INTERFACE (A)**

**LOGON (U)**

- Select “File” > “Logon”.
- Login with user name “expert” and password “demo”. You now have administrative privileges.

**INSTALL LICENSE (A)**

If you do not install a license file BIOMA will run in demo mode. In this mode any changes applied to the example data set will not be saved.

- Select “Help” > “About”.
- Click “Install License”.
- Choose the license file (e.g. “company.license”) that you got when buying BIOMA. Click “Open”.
- Confirm the appearing message by clicking “OK”.
- Restart BIOMA.
- Logon again (use admin/demo with client licenses and expert/demo with developer licenses).

**OPEN PLANT DOCUMENT (U)**

- Select “File” > “Open Plant Document”.
- When BIOMA is run in demo mode the only plant document available is “Sample Plant (2010)”.

---

**USER MANUAL FOR PLANT ADMINS AND USERS**

---

**The letter in the bracket directly after a heading refers to necessary minimum access rights (user < administrator < expert < developer).**

**A user has only the rights to import operational data and display the results of the calculation for several parameters.**

**An administrator has the additional rights to perform plant and program configurations and to create report packages.**

**A developer has the additional rights to display and edit the calculation algorithm.**

**DEMO MODE**

When BIOMA is run in demo mode it is NOT possible to import data or report packages. All changes applied to the sample data will be deleted when the software is closed.

**SETUP OF BIOMA INTERFACE (A)**

**LOGON (U)**

- Select “File” > “Logon”.
- Login with user name “expert” and password “demo”. You now have administrative privileges.

![Login dialog](image)

**INSTALL LICENSE (A)**

If you do not install a license file BIOMA will run in demo mode. In this mode any changes applied to the example data set will not be saved.

- Select “Help” > “About”.
- Click “Install License”.
- Choose the license file (e.g. “company.license”) that you got when buying BIOMA. Click “Open”.
- Confirm the appearing message by clicking “OK”.
- Restart BIOMA.
- Logon again (use admin/demo with client licenses and expert/demo with developer licenses).

**OPEN PLANT DOCUMENT (U)**

- Select “File” > “Open Plant Document”.
- When BIOMA is run in demo mode the only plant document available is “Sample Plant (2010)”. 
When BIOMA is run with a valid license for the first time a new plant document with the name “New plant created at [date time]” is available. Select this entry if you want to design a plant document from scratch.

If plant documents have already been created with a previous version of BIOMA and the SQL database has been left untouched, all plant documents available in this database should be displayed.

- Select a plant document, tick “Open on program start” and click “OK”.

EDIT PLANT CONFIGURATION (A)

- Select “Edit” > “Edit Plant Configuration”.
- On tab “Plant” you can enter plant name, address and optionally remarks.

- On tab “Contact Person” you can enter name, email, telephone and fax of a contact person.
On tab “Parameters” edit plant specific parameters (if necessary). The default settings are taken from C:\Program Files\inka software\BIOMA 2.0.1301\Template\Parameter.xls. The following settings can be changed.

Column “Data Source”:
- “Default” values will be the same during online calculation and in report package.
- “Manual” and Manual total” values have to be updated manually when creating a report package. “Manual” values represent relations [e.g. kg/kg] while “Manual total” values represent mass and volume flows over the total reporting period.
- “Control System” values are directly produced from the control system and will be imported via CSV file.
- “None” should be chosen if a parameter is not necessary for calculation (e.g. if no sludge is burned choose “none” for “mslu”). IMPORTANT: Make sure that you also tick “Use defaults” and enter 0 in column “Value”!

Column “Use defaults”:
- If the tick “use defaults” is set it indicates that during online calculation the default settings (mean value and standard deviation) should be used (if given) when no data is available from the chosen source (“Control System”, “Manual”, “Manual Total”) or if “Default” or “None” was selected.
- During online calculation the default values of variables with source “Manual” are always used.

Column “Value” and “Uncertainty”:
- Enter the mean value and the standard uncertainty of a parameter.

Column “+/ Manual [%]”:
- This standard uncertainty in % will be used during calculation. If it is not given it will be computed from the given mean value and absolute uncertainty.
- If the mouse pointer hovers over a short term of a parameter a detailed description is displayed as tooltip.

On tab “Oven Lines” click “+” to add one or more oven line.
- Select an existing oven line and click “…” to edit oven line properties.
- On tab “Common” edit name and display color of the oven line.

- On tab “Parameters” edit oven line specific parameters (if necessary).
IMPORT CONFIGURATION 1 (A)

- Select “Edit” > “Import Operation Data”.
- On tab “Import” select “Import of control system data from CSV file”.
- Click the “Settings” button to change the CSV import definition settings. Confirm the warning message by clicking “Yes”.

- On tab “Common” choose language, column separator, position of date column and first data row.
- Select an offset for Mwaste. This is the time from the moment the waste is taken from the bunker until combustion takes place. Best practice is 2 hours.

- On tab “Column mapping” you can edit already existing import settings or create new entries. The standard settings are displayed in the graph below.
- In the row that is marked by a “*” you can add a new import parameter by selecting a component (oven line), a parameter key and a column reference. The column reference can also contain functions of columns of the import file.
- Alternatively you can edit any already existing parameter by changing the entries in the respective row.
- Press “OK”.

[Diagram of Operating Data Import]

[Diagram of CSV - Import Configuration]
• If you want to import control system data automatically click “Close” (!).
• If you want to manually import a CSV file select a source file and click “Start”.

**IMPORT CONFIGURATION 2 (A)**

• Select “Extras” > “Options” > tab “Import”.
• Choose “Import Directory”. This is the folder where the CSV data file has to be placed in order to be automatically imported.
• Choose “Backup Directory”. If the data import was successful the CSV file will be moved from “Import Directory” to “Backup Directory”.
• Choose “Backup Directory”. If the data import was not successful the CSV file will be moved from “Import Directory” to “Error Directory”.
• Set Import interval (seconds) and tick “Enable import timer” to activate automatically importing of data. The “Import Directory” will be checked according to the time stated if new data is available.
• Set the number of backup files that should be kept before starting to delete the oldest.

**IMPORT DATA (U)**
- Enable your control system to automatically produce CSV files with aggregated data for one hour (every full hour!). The time e.g. 01:00 stands for the time interval >0:00 to 1:00.
- Copy these files automatically to the chosen “Import Directory”.
- These files must obey the settings from “Import Configuration 1”.

<table>
<thead>
<tr>
<th>Date</th>
<th>Mass</th>
<th>Vgas</th>
<th>Mol</th>
<th>Moleq</th>
<th>Temp</th>
<th>Psteam</th>
<th>TempH2O</th>
<th>VpH2O</th>
<th>CO2ppm</th>
<th>Vf</th>
<th>CO2ppm</th>
<th>c:CO2ppm</th>
</tr>
</thead>
<tbody>
<tr>
<td>21.04.2011</td>
<td>39.7</td>
<td>0</td>
<td>95.5</td>
<td>394.9</td>
<td>35</td>
<td>127.7</td>
<td>124034.2</td>
<td>8.2</td>
<td>10.69</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- As soon as the first 4 hours of plausible data are available a calculation will be performed and the results displayed in the Graphical User Interface (GUI).

**USE GRAPHICAL USER INTERFACE (U)**

- In the “Status Panel” on tab “Oven lines” select the oven lines you want to display in the graph.
- In the “Status Panel” on tab “Parameters” select the parameters you want to display in the graph.
  - You can assign as many parameters as you want to two different y axis (left and right)
  - As soon as a parameter is assigned to one of the y-axis its unit is fixed. From then on it is only possible to assign additional parameter with the same unit.
- If you want to show the results for a different time period
  - Select the “Calculation interval”
    - Past 8 hours (hour steps moving) = default setting, no date selection possible
    - 8 hours (hour steps moving)
    - 1 day (hours step moving)
    - 1 week (days steps)
    - 1 month (days steps)
    - 1 year (month steps)
  - Select the starting point of the calculation interval by pressing the date/time button or use the arrows to switch the display in steps of the size of the selected calculation interval.
- Each data point displayed in a graph with hourly resolution represents the calculation results of 4-hour-moving-average.
- If there are any troubles during calculation the related messages will be displayed inside of the “messages” window. To clear this window right click on it and choose “Clear output”.
- To show all calculation results of the chosen calculation interval select tab “Calculated data” in the “Status Panel”. Here you can select for which line and calculation step you want to display data. Additionally it is possible to export this information into an Excel file by pressing “Export”.
  **ATTENTION:** No calculation uncertainties will be displayed. This feature is only available for experts (via “Reporting” > “Export Online Calculation Results”).
Only experts can see the calculated results of all parameters. For administrators and users only a few of them are available per default (changes in this selection can only be applied by an expert):

- m\textsubscript{I} inert mass fraction (moisture free) in waste feed
- m\textsubscript{B} biogenic mass fraction (ash and moisture free) in waste feed
- m\textsubscript{F} fossil mass fraction (ash and moisture free) in waste feed
- m\textsubscript{W} mass fraction of water in waste feed
- H\textsubscript{v}totcorr lower heating value of the waste feed (corrected according to Kost)
- H\textsubscript{v}brelcorr ratio of energy produced from biogenic fraction (moisture free) to total energy produced (corrected according to Kost)
- CO\textsubscript{2}f carbon dioxide emitted from fossil fraction per ton waste

CREATE REPORT PACKAGE (A)

To transmit the recorded plant data to authorities for evaluation (or automatic creation of a pdf report) a report package has to be created.

- Select “Reporting” > “Export/Edit Report Package”.
- Select the reporting period (e.g. 01.01.2010 – 31.12.2010).
- Update plant parameters (“Common” and “Oven lines”). This update is needed to correct met assumptions that are necessary to perform online calculations.
- Click “Export”.
- Select a destination folder and click “Save” again.
IMPORT REPORT PACKAGE (A)

If you get support in form of an edited report package you have to import it.

- Select “Reporting” > “Import Report Package”.
- Select a report package (extension *.brpz).
- Click “Open”.

The plant document is afterwards available under “File” > “Open Plant Document”.
**MENU DESCRIPTION**

The letter in the bracket directly after the name of the menu entries refers to necessary minimum access rights (user < administrator < expert < developer).

A user has only the rights to import operational data and display the results of the calculation for several parameters.

An administrator has the addition rights to perform plant and program configurations and to create report packages.

An expert has the additional rights to edit operational data, to import report packages and to create reports.

A developer has the additional rights to display and edit the calculation algorithm.

**FILE**

**LOGON (U)**

- Enter “User Name” and “Password”.
- Directly after installation the following users can be used.

<table>
<thead>
<tr>
<th>User name</th>
<th>Password</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>expert</td>
<td>demo</td>
<td>expert (reports, calculation module, ...)</td>
</tr>
<tr>
<td>admin</td>
<td>demo</td>
<td>plant admin (plant configuration, program configuration, report packages, ...)</td>
</tr>
<tr>
<td>user</td>
<td>demo</td>
<td>employee (import of operational data)</td>
</tr>
</tbody>
</table>

- Select “Auto logon” if you want to logon automatically with the entered data when BIOMA is started.
LOGOFF (U)

Click “Logoff” to log off the currently logged in user.

OPEN PLANT DOCUMENT (U)

- Select the plant document you want to work with.
- Tick “Open on program start” if you want to open the selected plant document automatically when BIOMA is started.
- Click “OK”.

NEW PLANT DOCUMENT (E)

A new plant document based on the default settings of the “Parameter.xls” will be created.

SAVE AS A TEMPLATE (E)

An edited plant document can be saved as a template for further plant installations.

EXIT (U)

Click “Exit” for closing the software BIOMA.

EDIT

EDIT PLANT CONFIGURATION (A)

BUTTON “ADD NEW PARAMETERS” (D)

This button can be used to update the database with parameters that have been added to the file “Parameter.xls”. This is normally done automatically if the version number of the “Parameter.xls” is different from the plant document.

TAB “PLANT”

Enter plant data (plant name, address and remarks).
**TAB “CONTACT PERSON”**

Enter data of contact person (name, e-mail, telephone, fax).

**TAB “PARAMETERS”**

On this tab the settings for plant specific parameters (concerning fuels and materials) can be edited. The default settings are taken from C:\Program Files\inka software\BIOMA 2.0.1301\Template\Parameter.xls. The following settings can be changed:

Column “Data Source”:

- “Default” values will be the same during online calculation and in report package.
- “Manual” and Manual total” values have to be updated manually when creating a report package. “Manual” values represent relations [e.g. kg/kg] while “Manual total” values represent mass and volume flows over the total reporting period.
- “Control System” values are directly produced from the control system and will be imported via CSV file.
- “None” should be chosen if a parameter is not necessary for calculation (e.g. if no sludge is burned choose “none” for “mslu”). IMPORTANT: Make sure that you also tick “Use defaults” and enter 0 in column “Value”!

Column “Use defaults”:
• If the tick “use defaults” is set it indicates that during online calculation the default settings (mean value and standard deviation) should be used (if given) when no data is available from the chosen source (“Control System”, “Manual”, “Manual Total”) or if “Default” or “None” was selected
• During online calculation the default values of variables with source “Manual” are always used.

Column “Value” and “Uncertainty”:
• Enter the mean value and the standard uncertainty of a parameter.

Column “+/ Manual [%]”:
• This standard uncertainty in % will be used during calculation. If it is not given it will be computed from the given mean value and absolute uncertainty.

If the mouse pointer hovers over a short term of a parameter a detailed description is displayed as tooltip.

<table>
<thead>
<tr>
<th>Column</th>
<th>Value</th>
<th>Uncertainty</th>
</tr>
</thead>
<tbody>
<tr>
<td>H2O2</td>
<td>0.74</td>
<td>7.05%</td>
</tr>
<tr>
<td>H2O</td>
<td>0.4</td>
<td>10.00%</td>
</tr>
</tbody>
</table>

**TAB “OVEN LINES”**

• Click “+” to add an oven line.
• Select an existing oven line and click “-” to delete it.
• Select an existing oven line and click “…” to edit oven line properties.

**EDIT OVEN LINE PROPERTIES (A)**

This is a subsection of “Edit Plant Configuration”.

• In the menu select “Edit” > “Edit Plant Configuration”.
• On tab “Oven lines” select an existing oven line and click “…” to edit oven line properties.
**TAB “COMMON”**

Enter oven line data (name, color and remarks).

**TAB “PARAMETERS”**

On this tab the settings for oven line specific parameters (concerning combustion air, fuels, incineration ash, steam loop, total values for reporting period) can be edited. The default settings are taken from C:\Program Files\inka software\BIOMA 2.0.1301\Template\Parameter.xls. The following settings can be changed:

Column “Data Source”:

- “Default” values will be the same during online calculation and in report package.
- “Manual” and Manual total” values have to be updated manually when creating a report package. “Manual” values represent relations [e.g. kg/kg] while “Manual total” values represent mass and volume flows over the total reporting period.
- “Control System” values are directly produced from the control system and will be imported via CSV file.
- “None” should be chosen if a parameter is not necessary for calculation (e.g. if no sludge is burned choose “none” for “mslu”). IMPORTANT: Make sure that you also tick “Use defaults” and enter 0 in column “Value”!

Column “Use defaults”:

- If the tick “use defaults” is set it indicates that during online calculation the default settings (mean value and standard deviation) should be used (if given) when no data is available from the chosen source (“Control System”, “Manual”, “Manual Total”) or if “Default” or “None” was selected.
- During online calculation the default values of variables with source “Manual” are always used.

Column “Value” and “Uncertainty”:

- Enter the mean value and the standard uncertainty of a parameter.

Column “+/- Manual [%]”:

- This standard uncertainty in % will be used during calculation. If it is not given it will be computed from the given mean value and absolute uncertainty.

If the mouse pointer hovers over a short term of a parameter a detailed description is displayed as tooltip.
IMPORT OPERATION DATA (U)

TAB “IMPORT”

This window can be used to manually import operational data.

- Select “Import of control system data from CSV file”.
- Click “Settings” to change the CSV import definition settings (admins only)
- Select a source file.
- Click “Start”.

TAB “PROTOCOLS”

This window displays protocols with details about the data import.
This is a subsection of “Import Operation Data”.

- In the menu select “Edit” > “Import Operation Data”.
- On tab “Import” click “Settings” to change the CSV import definition settings.

**TAB “COMMON”**

Edit the general settings for importing the data from of the CSV file.

- Select language, column separator, date column and first data row.
- Select an offset for Mwaste. This is the time from the moment the waste is taken from the bunker until combustion takes place. Best practice is two hours. That means that the measured mass of waste for a point in time will be assigned to the remaining data set measured two hours later.

**TAB “COLUMN MAPPING”**

Edit the column mapping (which column contains which parameter) of the CSV.

- Add a parameter by selecting an oven line, a parameter key and a column reference in the row with the “*”. The column reference can also contain functions of columns of the import file.
- Delete a parameter by selecting the grey box in front of a parameter row and pressing delete.
EDIT OPERATION DATA (E)

- Select Period.
- Select Component (oven line or plant).
- Click “Query”.
- Edit the displayed data.
- Click “Apply” or “OK”.

CALCULATE (U)

- Enter date and time.
- Click “OK”.

Alternatively you can click the date button on the Status Panel of the GUI.
SHOW GENERATED SOURCE (D)

This menu entry displays the automatically generated source code necessary to access the parameters via names within the calculation source code.

![View Generated Source Code]

EDIT CALCULATION SOURCE (D)

This menu entry offers the possibility to edit the calculation source code directly from within BIOMA.

![Edit Calculation Source Code]

REPORTING

EXPORT / EDIT REPORT PACKAGE (A)

To transmit the recorded plant data to authorities for evaluation a report package has to be created.

TAB “COMMON”

- Select the reporting period.
• Update plant parameters. These updates are needed to correct met assumptions necessary for the online calculation.

TAB “LINE X”

• On bottom tab “Values for Reporting period” update oven line parameters. These updates are needed to correct met assumptions necessary for the online calculation.

• On bottom tab “Adjustments (O₂, CO₂)” adjustments for O₂ and CO₂ measurements can be entered. This might be necessary because O₂ and CO₂ calibration of measuring devices are normally performed with calibration gases that have a higher concentration than optimal for the balance method. Because of that it is recommended to repeat the measurements with calibration gases that contain concentrations in the height of the expected values and enter this information into BIOMA.
Click “Export”. Select a destination folder and click “Save”.
Alternatively you can click “Save” to store the changes of updated plant parameters in the internal database only without creating a report package.
IMPORT REPORT PACKAGE (A)

Select a saved report package (extension *.brp) or a compressed report package (extension *.brpz) and click “Open”.

BUILDING REPORTS (E)

Here you can build a report from the imported data or report package.

- Select the reporting period. The beginning and the end of the reporting period can only be chosen within the time frame of the created or imported report package.
- Select an alternative report template (Bioma.xrpt). These templates written in XML are editable.
- Select reporting steps (Days, Weeks, Months, Years). This selection should fit to the chosen report template. Default setting is “Months”.
- Tick “Use default values instead of manual inputs” if you want to ignore the manually entered data during creation of a report package and use the default values instead.
- Click “Calculate report data”.
- The button “Chart Editor” can be used to edit existing charts for the report (data binding is written in XML).
- The button “Text Modules” can be used to write user defined text that can be implemented in the report template via XML code.

- Click “Publish” to create a pdf report based on the report template.
- Or click “Export” to export the results of plausibility checks and the results of the calculation steps to several Excel files (one for each oven line and one for the whole plant).

- Click “Close” to close the window. You will be asked if you want to store the results of you calculations. If you click “Yes” you do not have to repeat the calculation when opening the “Report Building Form” again.
This is especially useful if you are working on the layout of your report template and only want to view the results of the PDF creation process when clicking “Publish”.

EXPORT ONLINE CALCULATION RESULTS (E)

You can use this function to export the online calculation results of the displayed graph to several Excel files. These files contain the results of the plausibility checks and the calculation results including uncertainties.

EXTRAS

OPTIONS (A)

TAB “DATABASE”

If the standard installation of the database server has been performed nothing has to be changed. If a different database server should be accessed or e.g. Windows authentication shall be used, the settings have to be edited here.

TAB “CALCULATION”

- Set Message level (none < error < warnings < information < detail).
- Set Calculation method (Default method, Source code (necessary for developers only)).
TAB “IMPORT”

- Choose “Import Directory”. This is the folder where the CSV data file has to be placed in order to be automatically imported.
- Choose “Backup Directory”. If the data import was successful the CSV file will be moved from “Import Directory” to “Backup Directory”.
- Choose “Backup Directory”. If the data import was not successful the CSV file will be moved from “Import Directory” to “Error Directory”.
- Set Import interval (seconds) and tick “Enable import timer” to activate automatically importing of data. The “Import Directory” will be checked according to the time stated if new data is available.
- Set the number of backup files that should be kept before starting to delete the oldest.

ADMINISTRATION (A)

PLANT DOCUMENT ADMIN (A)

- To delete a plant document tick the document and click “Remove Document”. The active document can’t be deleted.
- To delete only operational data tick the desired document and click “Delete Operation Data”.

BIOMA Menu Description ● 45
USERS AND PERMISSIONS (A)

Select one of the available users from the drop down menu to see the group (access rights) it belongs to.

- To edit or create a user click the “Edit user” or “Add new user” button.

- Edit or enter login name, password and name (will be displayed on top of GUI).
- Click “OK”.

- Select a group membership (experts > administrators > WIP employees [short for Waste Incineration Plant])
- Click “OK”.

To delete a user
- Select the user from the dropdown menu and click the “Remove user” button.
- Click “OK”.

HELP (U)

ABOUT (A)

- Click “Install License” to install an acquired license (e.g. XYZ.license).
- Licenses can only be created with developer rights. Please contact TU Vienna.